Avoid prefix boolean returning method with `get`

Metadata

ID: java-code-style/boolean-get-method-name

Language: Java

Severity: Notice

Category: Code Style

Description

To improve readability, methods that return a boolean should be named accordingly. Instead of prefixing a method with get, consider using is, has, can, or will .

Non-Compliant Code Examples

public class Foo {
    public boolean getFoo(); // you are not getting foo
}

Compliant Code Examples

public class Foo {
    public boolean isFoo();
}