ASM capabilities

The following ASM capabilities are supported in the Go library, for the specified tracer version:

ASM capabilityMinimum Go tracer version
Threat Detection1.47.0
API Security1.59.0
Threat Protection1.50.0
Customize response to blocked requests1.53.0
Software Composition Analysis (SCA)1.49.0
Code Security (beta)not supported
Automatic user activity event trackingnot supported

The minimum tracer version to get all supported ASM capabilities for Go is 1.59.0.

Note: Threat Protection requires enabling Remote Configuration, which is included in the listed minimum tracer version.

Supported deployment types

TypeThreat Detection supportVulnerability Management for OSS support
Docker
Kubernetes
Amazon ECS
AWS Fargate
AWS Lambda

Language and framework compatibility

Supported Go versions

The Datadog Go Tracing library is open source. View the GitHub repository for more information.

The Datadog Go Tracing Library has a version support policy defined for Go versions. The two latest releases of Go are fully supported, while the third newest release is considered in maintenance. Older versions may function, but no support is provided by default. For special requests, contact support.

You must be running Datadog Agent v5.21.1+

Starting from tracer version 1.53.0, ASM does not require CGO.

Integrations

The Go tracer includes support for the following frameworks, data stores and libraries.

The Go packages listed in this page are relevant for ASM. You can also find more tracing integrations in APM’s tracing compatibility page.

Note: The Go integrations documentation provides a detailed overview of the supported packages and their APIs, along with usage examples.

If you don't see your library of choice listed, fill out this form to send details.

Web framework compatibility

FrameworkThreat Detection supported?Threat Protection supported?
net/http
Gin
Gorilla Mux
gRPC
echo v4
echo v3
chi
graphql-go
gqlgen

Networking framework compatibility

FrameworkThreat Detection supported?Threat Protection supported?
gRPC client
net/http client

Data store compatibility

FrameworkThreat Detection supported?Threat Protection supported?
sql