Avoid prefix boolean returning method with `get`

이 페이지는 아직 한국어로 제공되지 않으며 번역 작업 중입니다. 번역에 관한 질문이나 의견이 있으시면 언제든지 저희에게 연락해 주십시오.

Metadata

ID: java-code-style/boolean-get-method-name

Language: Java

Severity: Notice

Category: Code Style

Description

To improve readability, methods that return a boolean should be named accordingly. Instead of prefixing a method with get, consider using is, has, can, or will .

Non-Compliant Code Examples

public class Foo {
    public boolean getFoo(); // you are not getting foo
}

Compliant Code Examples

public class Foo {
    public boolean isFoo();
}
https://static.datadoghq.com/static/images/logos/github_avatar.svg https://static.datadoghq.com/static/images/logos/vscode_avatar.svg jetbrains

Seamless integrations. Try Datadog Code Analysis