Python Compatibility Requirements
Incident Management が一般に使用できるようになりました。 Incident Management が広範に使用できるようになりました。

Python Compatibility Requirements


The Python Datadog Trace library is open source. View the Github repository for more information.

Python versions 2.7+ and 3.5+ are supported in the latest version of the tracer. Python 3.4 is supported in versions 0.35.x and below of the Python tracer.


To request support for additional libraries, contact our awesome support team.

Web Framework Compatibility

The ddtrace library includes support for a number of web frameworks, including:

FrameworkSupported VersionLibrary Documentation
aiohttp>= 1.2
Bottle>= 0.11
Django>= 1.8
djangorestframework>= 3.4
Falcon>= 1.0
Flask>= 0.10
Molten>= 0.7.0
Pylons>= 0.9.6
Pyramid>= 1.7
Sanic>= 19.6.0
Starlette>= 0.13.0
Tornado>= 4.0

Datastore Compatibility

The ddtrace library includes support for the following data stores:

DatastoreSupported VersionLibrary Documentation
Cassandra>= 3.5
Elasticsearch>= 1.6
Flask Cache>= 0.12
Memcached pylibmc>= 1.4
Memcached pymemcache>= 1.3
MongoDB Mongoengine>= 0.11
MongoDB Pymongo>= 3.0
MySQL MySQL-python>= 1.2.3
MySQL mysqlclient>= 1.3
MySQL mysql-connector>= 2.1
Postgres aiopg>= 0.12.0
Postgres psycopg>= 2.4
Redis>= 2.6
Redis redis-py-cluster>= 1.3.5
SQLAlchemy>= 1.0
SQLite3Fully Supported
Vertica>= 0.6

Library Compatibility

The ddtrace library includes support for the following libraries:

LibrarySupported VersionLibrary Documentation
asyncioFully Supported
gevent>= 1.0
aiobotocore>= 0.2.3
Boto2>= 2.29.0
Botocore>= 1.4.51
Celery>= 4.0.2
FuturesFully Supported
Grpc>= 1.8.0
httplibFully Supported
Jinja2>= 2.7
Kombu>= 4.0
Mako>= 0.1.0
Requests>= 2.08

Further Reading