Python 互換性要件
Dash が新機能を発表!インシデントマネジメント、Continuous Profiler など多数の機能が追加されました! Dash イベントで発表された新機能!

Python 互換性要件

Python Datadog Trace ライブラリはオープンソースです。詳細については、Github リポジトリをご覧ください。

Python 2.7 および 3.4 バージョン以降がサポートされます。

インテグレーション

ライブラリに関するサポートをご希望の場合は、サポートチームまでお気軽にお問い合わせください。

Web フレームワークの互換性

ddtrace ライブラリには、次のような数多くの Web フレームワークのサポートが含まれています。

フレームワークサポート対象のバージョンPyPi Datadog ドキュメント
aiohttp1.2 以降http://pypi.datadoghq.com/trace/docs/web_integrations.html#aiohttp
Bottle0.11 以降http://pypi.datadoghq.com/trace/docs/web_integrations.html#bottle
Django1.8 以降http://pypi.datadoghq.com/trace/docs/web_integrations.html#django
djangorestframework3.4 以降http://pypi.datadoghq.com/trace/docs/web_integrations.html#django
Falcon1.0 以降http://pypi.datadoghq.com/trace/docs/web_integrations.html#falcon
Flask0.10 以降http://pypi.datadoghq.com/trace/docs/web_integrations.html#flask
Molten0.7.0 以降http://pypi.datadoghq.com/trace/docs/web_integrations.html#molten
Pylons0.9.6 以降http://pypi.datadoghq.com/trace/docs/web_integrations.html#pylons
Pyramid1.7 以降http://pypi.datadoghq.com/trace/docs/web_integrations.html#pyramid
Tornado4.0 以降http://pypi.datadoghq.com/trace/docs/web_integrations.html#tornado

データストアの互換性

ddtrace ライブラリには、次のデータストアのサポートが含まれています。

data storeサポート対象のバージョンPyPi Datadog ドキュメント
Cassandra3.5 以降http://pypi.datadoghq.com/trace/docs/db_integrations.html#cassandra
Elasticsearch1.6 以降http://pypi.datadoghq.com/trace/docs/db_integrations.html#elasticsearch
Flask Cache0.12 以降http://pypi.datadoghq.com/trace/docs/db_integrations.html#flask-cache
Memcached pylibmc1.4 以降http://pypi.datadoghq.com/trace/docs/db_integrations.html#pylibmc
Memcached pymemcache1.3 以降http://pypi.datadoghq.com/trace/docs/db_integrations.html#pymemcache
MongoDB Mongoengine0.11 以降http://pypi.datadoghq.com/trace/docs/db_integrations.html#mongoengine
MongoDB Pymongo3.0 以降http://pypi.datadoghq.com/trace/docs/db_integrations.html#pymongo
MySQL MySQL-python1.2.3 以降http://pypi.datadoghq.com/trace/docs/db_integrations.html#module-ddtrace.contrib.mysqldb
MySQL mysqlclient1.3 以降http://pypi.datadoghq.com/trace/docs/db_integrations.html#module-ddtrace.contrib.mysqldb
MySQL mysql-connector2.1 以降http://pypi.datadoghq.com/trace/docs/db_integrations.html#mysql-connector
Postgres aiopg0.12.0 以降http://pypi.datadoghq.com/trace/docs/db_integrations.html#aiopg
Postgres psycopg2.4 以降http://pypi.datadoghq.com/trace/docs/db_integrations.html#module-ddtrace.contrib.psycopg
Redis2.6 以降http://pypi.datadoghq.com/trace/docs/db_integrations.html#redis
Redis redis-py-cluster1.3.5 以降http://pypi.datadoghq.com/trace/docs/db_integrations.html#module-ddtrace.contrib.rediscluster
SQLAlchemy1.0 以降http://pypi.datadoghq.com/trace/docs/db_integrations.html#sqlalchemy
SQLite3完全対応http://pypi.datadoghq.com/trace/docs/db_integrations.html#sqlite
Vertica0.6 以降http://pypi.datadoghq.com/trace/docs/db_integrations.html#vertica

ライブラリの互換性

ddtrace ライブラリには、次のライブラリのサポートが含まれています。

ライブラリサポート対象のバージョンPyPi Datadog ドキュメント
asyncio完全対応http://pypi.datadoghq.com/trace/docs/async_integrations.html#asyncio
gevent1.0 以降http://pypi.datadoghq.com/trace/docs/async_integrations.html#gevent
aiobotocore0.2.3 以降http://pypi.datadoghq.com/trace/docs/other_integrations.html#aiobotocore
Boto22.29.0 以降http://pypi.datadoghq.com/trace/docs/other_integrations.html#boto2
Botocore1.4.51 以降http://pypi.datadoghq.com/trace/docs/other_integrations.html#botocore
Celery4.0.2 以降http://pypi.datadoghq.com/trace/docs/other_integrations.html#celery
Futures完全対応http://pypi.datadoghq.com/trace/docs/other_integrations.html#futures
Grpc1.8.0 以降http://pypi.datadoghq.com/trace/docs/other_integrations.html#grpc
httplib完全対応http://pypi.datadoghq.com/trace/docs/other_integrations.html#httplib
Jinja22.7 以降http://pypi.datadoghq.com/trace/docs/other_integrations.html#jinja2
Kombu4.0 以降http://pypi.datadoghq.com/trace/docs/other_integrations.html#kombu
Mako0.1.0 以降http://pypi.datadoghq.com/trace/docs/other_integrations.html#mako
Requests2.08 以降http://pypi.datadoghq.com/trace/docs/other_integrations.html#requests

その他の参考資料

お役に立つドキュメント、リンクや記事: