.NET Framework Compatibility Requirements

Cette page n'est pas encore disponible en français, sa traduction est en cours.
Si vous avez des questions ou des retours sur notre projet de traduction actuel, n'hésitez pas à nous contacter.

The .NET Tracer supports all .NET-based languages (for example, C#, F#, Visual Basic). It is open source. For more information, see the .NET Tracer repository.

Supported .NET Framework runtimes

The .NET Tracer supports automatic and custom instrumentation on the following .NET Framework versions. It also supports .NET Core.

.NET Framework VersionMicrosoft End of LifeSupport levelPackage versionDatadog End of Life
4.8GAlatest
4.7.2GAlatest
4.7GAlatest
4.6.2GAlatest
4.6.104/26/2022GAlatest
4.604/26/2022EOL< 2.0.0 (e.g. 1.31.2)04/26/2022
4.5.204/26/2022EOL< 2.0.0 (e.g. 1.31.2)04/26/2022
4.5.101/12/2016EOL< 2.0.0 (e.g. 1.31.2)04/26/2022
4.501/12/2016EOL< 2.0.0 (e.g. 1.31.2)04/26/2022

Additional information can be found within Microsoft’s .NET Core Lifecycle Policy and in Runtime support policy for .NET Framework APM.

Note: When deciding which tracer version to use for an automatic instrumentation, use the .NET Framework version installed on the application server. For example, if you compile your application to target .NET Framework 4.5.1, but the application runs on a server that has .NET Framework 4.8 installed, use the latest version of the tracer. To determine which version of .NET Framework is installed on a machine, follow the guidance provided by Microsoft.

Supported processor architectures

The .NET Tracer supports automatic instrumentation on the following architectures:

Processor architecturesSupport levelPackage version
Windows x86 (win-x86)GAlatest
Windows x64 (win-x64)GAlatest

Integrations

The latest version of the .NET Tracer can automatically instrument the following libraries:

Framework or libraryNuGet packageIntegration Name
ADO.NETAll AdoNet integrationsAdoNet
AerospikeAerospike.Client 4.0.0+Aerospike
ASP.NET (including Web Forms)built-inAspNet
ASP.NET MVCMicrosoft.AspNet.Mvc 4.0+AspNetMvc
ASP.NET Web API 2Microsoft.AspNet.WebApi 5.1+AspNetWebApi2
AWS SQSAWSSDK.SQS 3.0+AwsSqs
CosmosDbMicrosoft.Azure.Cosmos.Client 3.6.0+CosmosDb
CouchbaseCouchbaseNetClient 2.2.8+Couchbase
ElasticsearchElasticsearch.Net 5.3.0+ElasticsearchNet
GraphQL .NETGraphQL 2.3.0+GraphQL
gRPCGrpc.Core 2.3.0+Grpc
HttpClient / HttpMessageHandlerbuilt-inHttpMessageHandler
KafkaConfluent.Kafka 1.4+Kafka
MongoDBMongoDB.Driver.Core 2.1.0+MongoDb
MSMQbuilt-inMsmq
MySqlMySql.Data 6.7.0+
MySqlConnector 0.61.0+
MySql
OracleOracle.ManagedDataAccess 4.122.0+Oracle
PostgreSQLNpgsql 4.0+Npgsql
RabbitMQRabbitMQ.Client 3.6.9+RabbitMQ
Redis (ServiceStack client)ServiceStack.Redis 4.0.48+ServiceStackRedis
Redis (StackExchange client)StackExchange.Redis 1.0.187+StackExchangeRedis
SQLiteSystem.Data.Sqlite 2.0.0+
Microsoft.Data.Sqlite 1.0.0+
Sqlite
SQL ServerSystem.Data 4.0.0+
System.Data.SqlClient 4.0.0+
Microsoft.Data.SqlClient 1.0.0+
SqlClient
WCF (server)built-inWcf
WebClient / WebRequestbuilt-inWebRequest

Don’t see your desired libraries? Datadog is continually adding additional support. Check with the Datadog team for help.

Supported Datadog Agent versions

Datadog Agent versionPackage version
7.xlatest
6.xlatest
5.xlatest

Runtime support policy for .NET Framework APM

Datadog APM for .NET Framework depends on the host operating system, .NET Framework runtime, certain .NET Framework libraries, and the Datadog Agent/API. These third party software systems support specific versions of .NET Framework. When the external software no longer supports a version of .NET Framework, Datadog APM for .NET Framework also limits its support for that version.

Levels of support

LevelSupport provided
UnsupportedNo implementation. Contact customer support for special requests.
BetaInitial implementation. May not yet contain all features. Support for new features, bug & security fixes provided on a best-effort basis.
General Availability (GA)Full implementation of all features. Full support for new features, bug & security fixes.
MaintenanceFull implementation of existing features. Does not receive new features. Support for bug & security fixes only.
End-of-life (EOL)No support.

Package versioning

Datadog APM for .NET Framework practices semantic versioning. Version updates imply the following changes to runtime support:

  • Major version updates (for example 1.0.0 to 2.0.0) may change support for any runtime from Beta/GA to Maintenance/EOL.
  • Minor version updates (for example 1.0.0 to 1.1.0) won’t lower the level of support for one runtime but may add support for one.
  • Patch version updates (for example 1.0.0 to 1.0.1) will not change support for any runtime.

Further reading

Documentation, liens et articles supplémentaires utiles: