Avoid prefix boolean returning method with `get`

This page is not yet available in Spanish. We are working on its translation.
If you have any questions or feedback about our current translation project, feel free to reach out to us!

Metadata

ID: java-code-style/boolean-get-method-name

Language: Java

Severity: Notice

Category: Code Style

Description

To improve readability, methods that return a boolean should be named accordingly. Instead of prefixing a method with get, consider using is, has, can, or will .

Non-Compliant Code Examples

public class Foo {
    public boolean getFoo(); // you are not getting foo
}

Compliant Code Examples

public class Foo {
    public boolean isFoo();
}
https://static.datadoghq.com/static/images/logos/github_avatar.svg https://static.datadoghq.com/static/images/logos/vscode_avatar.svg jetbrains

Seamless integrations. Try Datadog Code Analysis