Do not use weak ciphers

Metadata

ID: csharp-security/weak-cipher

Language: C#

Severity: Error

Category: Security

Description

The DESCryptoServiceProvider should only be used with legacy code for compatibility reasons. For new code, consider using the Aes class.

Learn More

Non-Compliant Code Examples

class MyClass {
    public static void weakEncryption()
    {
        DES des = new DESCryptoServiceProvider();
        CryptoStream encStream = new CryptoStream(fout, des.CreateEncryptor(desKey, desIV), CryptoStreamMode.Write);

    }
}
class MyClass {
    public static void weakEncryption()
    {
        DES des = new DESCryptoServiceProvider();
        CryptoStream encStream = new CryptoStream(fout, des.CreateEncryptor(desKey, desIV), CryptoStreamMode.Write);

    }
}