Supported Platforms

The Datadog Agent is supported on a range of widely used operating systems and platforms. If your operating system is not listed below, a source installation might work for you.

64-BIT X86

Operating systemOS versionsAgent 5 versionsAgent 6 versionsAgent 7 versions
Amazon Linux2
2022>= 6.40.0>= 7.40.0
2023>= 6.40.0>= 7.40.0
Debian (systemd)7.0 (wheezy)<= 6.35.2<= 7.35.2
>= 8.0 (jessie)
Debian (SysVinit)7.0 (wheezy)6.6.0 - 6.35.2<= 7.35.2
>= 8.0 (jessie)
Ubuntu12.04
>= 14.04
RedHat /
CentOS
5.0
>= 6.0<= 6.51.1<= 7.51.1
>= 7.0
AlmaLinux /
Rocky
>= 8.0>= 6.33.0>= 7.33.0
SUSE Enterprise Linux (systemd)11 SP4<= 6.32.4<= 7.32.4
>= 12.0
SUSE Enterprise Linux (SysVinit)11 SP46.16.0 - 6.33.07.16.0 - 7.33.0
OpenSUSE (systemd)>= 15.0
Fedora>= 26

A check mark ( ) indicates support for all minor and patch versions.

64-BIT ARM V8

Operating systemOS versionsAgent 6 versionsAgent 7 versions
Amazon Linux2>= 6.16.0>= 7.16.0
2022>= 6.40.0>= 7.40.0
2023>= 6.40.0>= 7.40.0
Debian (systemd)>= 9.0 (stretch)>= 6.16.0>= 7.16.0
Ubuntu>= 16.04>= 6.16.0>= 7.16.0
RedHat /
CentOS
>= 8.0>= 6.16.0>= 7.16.0
AlmaLinux /
Rocky
>= 8.0>= 6.33.0>= 7.33.0
Fedora>= 27>= 6.16.0>= 7.16.0
Operating systemOS versionsAgent 5 versionsAgent 6 versionsAgent 7 versionsNotes
Windows Server2008 R2<= 6.45.1<= 7.45.1Server 2008 R2 is affected by a known issue with clock drift and Go.
2012/R2<= 6.46.0<= 7.46.0
>= 2016
Windows7
8.1<= 6.46.0<= 7.46.0
>=10

A check mark ( ) indicates support for all minor and patch versions.

To install a specific version of the Windows Agent, see the installer list.

64-BIT X86

macOS versionAgent 5Agent 6Agent 7
10.10 - 10.11<= 5.11.3
10.12<= 6.34.0<= 7.34.0
10.13<= 6.38.2<= 7.38.2
>= 10.14>= 7.39.0

Apple ARM64

macOS versionAgent 7
>= 11.0>= 7.39.0

64-BIT X86 support

AgentDockerKubernetesAzure Stack HCI OS
5>= 1.141.3 - 1.8
6>= 1.14>= 1.3All versions
7>= 1.14>= 1.3All versions

64-BIT ARM V8 support

Agent 6 and 7 support the following 64-BIT ARM V8 platforms:

PlatformSupported versions64-BIT ARM V8 support64-BIT X86 support
Docker>= 1.14
Kubernetes>= 1.3

Agent 6 and 7 support the following AIX versions:

  • 6.1 TL9 SP6
  • 7.1 TL5 SP3
  • 7.2 TL3 SP0

Further reading

Additional helpful documentation, links, and articles: